<?xml version="1.0" encoding="ISO-8859-1"?><article xmlns:mml="http://www.w3.org/1998/Math/MathML" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<front>
<journal-meta>
<journal-id>0123-2126</journal-id>
<journal-title><![CDATA[Ingeniería y Universidad]]></journal-title>
<abbrev-journal-title><![CDATA[Ing. Univ.]]></abbrev-journal-title>
<issn>0123-2126</issn>
<publisher>
<publisher-name><![CDATA[Pontificia Universidad Javeriana]]></publisher-name>
</publisher>
</journal-meta>
<article-meta>
<article-id>S0123-21262011000200014</article-id>
<title-group>
<article-title xml:lang="es"><![CDATA[Implementando un mecanismo contra telefonía en internet no solicitada basándose en identidad Session Initiation Protocol (SIP)]]></article-title>
<article-title xml:lang="en"><![CDATA[Implementing an Anti-SPIT Mechanism Based on SIP Identity]]></article-title>
<article-title xml:lang="pt"><![CDATA[Implementando um mecanismo contra telefonia na internet não solicitada baseando-se em identidad Session Initiation Protocol (SIP)]]></article-title>
</title-group>
<contrib-group>
<contrib contrib-type="author">
<name>
<surname><![CDATA[Salcedo-Parra]]></surname>
<given-names><![CDATA[Octavio]]></given-names>
</name>
<xref ref-type="aff" rid="A01"/>
</contrib>
<contrib contrib-type="author">
<name>
<surname><![CDATA[Castellanos-Jaimes]]></surname>
<given-names><![CDATA[Lilia]]></given-names>
</name>
<xref ref-type="aff" rid="A02"/>
</contrib>
<contrib contrib-type="author">
<name>
<surname><![CDATA[Camacho-Vargas]]></surname>
<given-names><![CDATA[José Jairo]]></given-names>
</name>
<xref ref-type="aff" rid="A03"/>
</contrib>
</contrib-group>
<aff id="A01">
<institution><![CDATA[,Universidad Distrital Francisco José de Caldas Grupo Internet Inteligente Facultad de Ingeniería]]></institution>
<addr-line><![CDATA[Bogotá ]]></addr-line>
<country>Colombia</country>
</aff>
<aff id="A02">
<institution><![CDATA[,Universidad Distrital Francisco José de Caldas Grupo Internet Inteligente ]]></institution>
<addr-line><![CDATA[Bogotá ]]></addr-line>
<country>Colombia</country>
</aff>
<aff id="A03">
<institution><![CDATA[,Universidad Distrital Francisco José de Caldas Grupo Internet Inteligente ]]></institution>
<addr-line><![CDATA[Bogotá ]]></addr-line>
<country>Colombia</country>
</aff>
<pub-date pub-type="pub">
<day>00</day>
<month>07</month>
<year>2011</year>
</pub-date>
<pub-date pub-type="epub">
<day>00</day>
<month>07</month>
<year>2011</year>
</pub-date>
<volume>15</volume>
<numero>2</numero>
<fpage>535</fpage>
<lpage>556</lpage>
<copyright-statement/>
<copyright-year/>
<self-uri xlink:href="http://www.scielo.org.co/scielo.php?script=sci_arttext&amp;pid=S0123-21262011000200014&amp;lng=en&amp;nrm=iso"></self-uri><self-uri xlink:href="http://www.scielo.org.co/scielo.php?script=sci_abstract&amp;pid=S0123-21262011000200014&amp;lng=en&amp;nrm=iso"></self-uri><self-uri xlink:href="http://www.scielo.org.co/scielo.php?script=sci_pdf&amp;pid=S0123-21262011000200014&amp;lng=en&amp;nrm=iso"></self-uri><abstract abstract-type="short" xml:lang="es"><p><![CDATA[En años recientes, el Session Initiation Protocol (SIP) se ha convertido en un importante protocolo de señalización para VoIP, dada su potencialidad para realizar llamadas multimedia desde internet, luego de TCP, IP y HTTP; sin embargo, SIP es un protocolo flexible, por su capacidad para extender métodos y atributos. Actualmente, los proveedores de servicios de voz sobre redes IP VoIP son sistemas cerrados. Por eso, el Spam Over Internet Telephony (SPIT) como VoIP no solicitado se ha visto como un problema poco grave hoy en día. Desde una perspectiva reducida, se plantea que el SPIT es problema de saber quién se va a comunicar con quién y el SIP Identity como una solución, dado su potencial para manejar las identidades dentro de SIP. JAIN SIP API es uno de los API más robustos para SIP sobre Java; por eso se sugiere como herramienta para el desarrollo de software para SIP, dadas las bondades de Java como la independencia de plataforma, movilidad, entre otras.]]></p></abstract>
<abstract abstract-type="short" xml:lang="en"><p><![CDATA[Session Initiation Protocol (SIP) has become an important VoIP signaling protocol for its advantages in making Internet-based multimedia calls. The flexibility of the SIP protocol is due to its capacity to extend methods and attributes. In present, Ip VoIP voice service providers are non-open systems. This is why the Spam Over Internet Telephony (SPIT) does not currently pose any problem. Hence, SIP Identity is a solution for handling identities within SIP. In order to develop SIP software packages, JAIN SIP API, one of the most robust API's for Java-based SIP is used, thanks to advantages such as platform independence and mobility.]]></p></abstract>
<abstract abstract-type="short" xml:lang="pt"><p><![CDATA[Nos últimos anos, o Session Initiation Protocol (SIP) converteu-se em um importante protocolo de sinalização para VoIP, dada seu potencialidade para realizar ligações multimídia a partir da internet, depois do TCP, IP e HTTP; contudo, o SIP é um protocolo flexível, pela sua capacidade para estender métodos e atributos. Atualmente, os provedores de serviços de voz sobre redes IP VoIP são sistemas fechados. Por isso, o Spam Over Internet Telephony (SPIT) como VoIP não solicitado tem sido visto como um problema pouco grave hoje em dia. Desde uma perspectiva reduzida, se propõe que no SPIT o problema é saber quem vai comunicar-se com quem e o SIP Identity como uma solução, dado seu potencial para gerenciar as identidades dentro do SIP JAIN SIP API é um dos API mais robustos para SIP sobre Java; por isso é sugerida como ferramenta para o desenvolvimento de software para SIP, dadas as bondades de Java como a independência de plataforma, mobilidade, entre outras.]]></p></abstract>
<kwd-group>
<kwd lng="es"><![CDATA[SIP (protocolo de redes de computadores)]]></kwd>
<kwd lng="es"><![CDATA[protocolos de redes de computadores]]></kwd>
<kwd lng="es"><![CDATA[telefonía por internet]]></kwd>
<kwd lng="en"><![CDATA[Session Initiation Protocol (Computer network protocol)]]></kwd>
<kwd lng="en"><![CDATA[computer network protocols]]></kwd>
<kwd lng="en"><![CDATA[internet telephony]]></kwd>
<kwd lng="pt"><![CDATA[SIP (Protocolo de redes de computadores)]]></kwd>
<kwd lng="pt"><![CDATA[protocolos de redes de computadores]]></kwd>
<kwd lng="pt"><![CDATA[telefonia pela internet]]></kwd>
</kwd-group>
</article-meta>
</front><body><![CDATA[   <font face="verdana" size="2">      <p align="center"><b><font size="4">Implementando un mecanismo contra telefon&iacute;a en internet no solicitada bas&aacute;ndose en identidad Session Initiation Protocol (SIP)<sup>1</sup></font></b></p>      <p align="center"><b><font size="3">Implementing an Anti-SPIT Mechanism Based on SIP Identity<sup>2</sup></font></b></p>      <p align="center"><b><font size="3">Implementando um mecanismo contra telefonia na internet n&atilde;o solicitada baseando-se em identidad Session Initiation Protocol (SIP)<sup>3</sup></font></b></p>      <p align="center">Octavio Salcedo-Parra<sup>4</sup>    <br> Lilia Castellanos-Jaimes<sup>5</sup>    <br> Jos&eacute; Jairo Camacho-Vargas<sup>16</sup></p>      <p><sup>1</sup>Este art&iacute;culo fue desarrollado por el grupo de investigaci&oacute;n Internet Inteligente de la Universidad Distrital Francisco Jos&eacute; de Caldas, Bogot&aacute;, Colombia.     <br> <sup>2</sup>Submitted on: November 19, 2010. Accepted on: May 30, 2011. This article was developed by the research group on Intelligent Internet of the Universidad Distrital Francisco Jos&eacute; de Caldas, Bogot&aacute;, Colombia.     <br> <sup>3</sup>Data de recep&ccedil;&atilde;o: 19 de novembro de 2010. Data de aceita&ccedil;&atilde;o: 30 de maio de 2011. Este artigo foi desenvolvido pelo grupo de pesquisa Internet Inteligente da Universidad Distrital Francisco Jos&eacute; de Caldas, Bogot&aacute;, Col&ocirc;mbia.     ]]></body>
<body><![CDATA[<br> <sup>4</sup>Ingeniero de sistemas, Universidad Distrital, Bogot&aacute;, Colombia. Mag&iacute;ster en Teleinform&aacute;tica, Universidad de los Andes, Bogot&aacute;, Colombia. Decano de la Facultad de Ingenier&iacute;a, docente de la Maestr&iacute;a en Ciencias de la Informaci&oacute;n y las Comunicaciones y director cient&iacute;fico del Grupo Internet Inteligente, Universidad Distrital Francisco Jos&eacute; de Caldas. Correo electr&oacute;nico: <a href="mailto:osalcedo@udistrital.edu.co">osalcedo@udistrital.edu.co</a>.     <br> <sup>5</sup>Ingeniero de sistemas, Universidad Industrial de Santander, Bucaramanga, Colombia. Estudiante Maestr&iacute;a en Ciencias de la Informaci&oacute;n y las Comunicaciones, Universidad Distrital Francisco Jos&eacute; de Caldas, Bogot&aacute;, Colombia. Integrante del Grupo Internet Inteligente, Universidad Distrital Francisco Jos&eacute; de Caldas. Correo electr&oacute;nico: <a href="mailto:lilia.castellanos@gmail.com">lilia.castellanos@gmail.com</a>.     <br> <sup>6</sup>Ingeniero de Sistemas, Universidad Distrital Francisco Jos&eacute; de Caldas, Bogot&aacute;, Colombia. Integrante del Grupo Internet Inteligente, Universidad Distrital Francisco Jos&eacute; de Caldas. Correo electr&oacute;nico: <a href="mailto:joscjai@gmail.com">joscjai@gmail.com</a>.</p>      <p>Fecha de recepci&oacute;n: 19 de noviembre de 2010. Fecha de aceptaci&oacute;n: 30 de mayo de 2011.</p>  <hr>      <p><b><font size="3">Resumen</font></b></p>      <p>En a&ntilde;os recientes, el Session Initiation Protocol (SIP) se ha convertido en un importante protocolo de se&ntilde;alizaci&oacute;n para VoIP, dada su potencialidad para realizar llamadas multimedia desde internet, luego de TCP, IP y HTTP; sin embargo, SIP es un protocolo flexible, por su capacidad para extender m&eacute;todos y atributos. Actualmente, los proveedores de servicios de voz sobre redes IP VoIP son sistemas cerrados. Por eso, el <i>Spam Over Internet Telephony</i> (SPIT) como VoIP no solicitado se ha visto como un problema poco grave hoy en d&iacute;a. Desde una perspectiva reducida, se plantea que el SPIT es problema de saber qui&eacute;n se va a comunicar con qui&eacute;n y el SIP Identity como una soluci&oacute;n, dado su potencial para manejar las identidades dentro de SIP. JAIN SIP API es uno de los API m&aacute;s robustos para SIP sobre Java; por eso se sugiere como herramienta para el desarrollo de software para SIP, dadas las bondades de Java como la independencia de plataforma, movilidad, entre otras.</p>      <p><b>Palabras clave</b>: SIP (protocolo de redes de computadores), protocolos de redes de computadores, telefon&iacute;a por internet.</p>  <hr>      <p><b><font size="3">Abstract</font></b></p>      <p>Session Initiation Protocol (SIP) has become an important VoIP signaling protocol for its advantages in making Internet-based multimedia calls. The flexibility of the SIP protocol is due to its capacity to extend methods and attributes. In present, Ip VoIP voice service providers are non-open systems. This is why the Spam Over Internet Telephony (SPIT) does not currently pose any problem. Hence, SIP Identity is a solution for handling identities within SIP. In order to develop SIP software packages, JAIN SIP API, one of the most robust API's for Java-based SIP is used, thanks to advantages such as platform independence and mobility.</p>      <p><b>Key words:</b> Session Initiation Protocol (Computer network protocol), computer network protocols, internet telephony.</p>  <hr>      ]]></body>
<body><![CDATA[<p><b><font size="3">Resumo</font></b></p>      <p>Nos &uacute;ltimos anos, o Session Initiation Protocol (SIP) converteu-se em um importante protocolo de sinaliza&ccedil;&atilde;o para VoIP, dada seu potencialidade para realizar liga&ccedil;&otilde;es multim&iacute;dia a partir da internet, depois do TCP, IP e HTTP; contudo, o SIP &eacute; um protocolo flex&iacute;vel, pela sua capacidade para estender m&eacute;todos e atributos. Atualmente, os provedores de servi&ccedil;os de voz sobre redes IP VoIP s&atilde;o sistemas fechados. Por isso, o <i>Spam Over Internet Telephony</i> (SPIT) como VoIP n&atilde;o solicitado tem sido visto como um problema pouco grave hoje em dia. Desde uma perspectiva reduzida, se prop&otilde;e que no SPIT o problema &eacute; saber quem vai comunicar-se com quem e o SIP Identity como uma solu&ccedil;&atilde;o, dado seu potencial para gerenciar as identidades dentro do SIP JAIN SIP API &eacute; um dos API mais robustos para SIP sobre Java; por isso &eacute; sugerida como ferramenta para o desenvolvimento de software para SIP, dadas as bondades de Java como a independ&ecirc;ncia de plataforma, mobilidade, entre outras.</p>      <p><b>Palavras chave:</b> SIP (Protocolo de redes de computadores), protocolos de redes de computadores, telefonia pela internet.</p>  <hr>      <p><b><font size="3">Introducci&oacute;n</font></b></p>      <p>El <i>Session Initiation Protocol </i>(SIP) como protocolo para iniciar, mantener y terminar una llamada es muy eficiente en cuanto a la cantidad de pasos que propone; sin embargo, los mecanismos existentes en SIP son inadecuados para asegurar criptogr&aacute;ficamente la identidad del usuario final que origina las peticiones SIP sobre todo en un escenario interdominios. Para ello SIP Identitiy define dos campos nuevos, para la cabecera SIP:</p>  <ul>     <li><i>Identity:</i> usada para llevar la firma usada para validad la identidad.</li>     <li><i>e Identitiy-Info:</i> para llevar una referencia hacia el certificado del firmante (Peterson y Jennings, 2006).</li>     </ul>      <p>Una identidad es definida como un Uniform resource Identifier (URI) SIP tambi&eacute;n llamada direcci&oacute;n de registro (Address of Record &#91;AoR&#93;), empleado para alcanzar a un usuario (por ejemplo, sip:jose@ud.com). La especificaci&oacute;n de SIP no se&ntilde;ala una forma para que el receptor de la petici&oacute;n SIP verifique que el campo de la cabecera <i>From</i> ha sido correctamente diligenciada en ausencia de alg&uacute;n tipo de autenticaci&oacute;n criptogr&aacute;fica (<a href="#f1">Figura 1</a>). </p>      <p align="center"><a name="f1"><img src="img/revistas/inun/v15n2/v15n2a14f1.jpg"></a></p>      ]]></body>
<body><![CDATA[<p>Actualmente son pocos los agentes de usuario (AU) que soportan certificados del usuario final, necesario para autenticarse entre ellos (por ejemplo, S/MIME); de igual forma, la autenticaci&oacute;n <i>Digest</i> est&aacute; limitada, en cuanto a que el emisor y el receptor deben compartir un secreto predeterminado (Franks et &aacute;l., 1999). El uso de muchas aplicaciones y servicios como SIP est&aacute;n regulados por pol&iacute;ticas de autorizaci&oacute;n. Estas pol&iacute;ticas pueden ser automatizadas o aplicadas por humanos: tal como en el celular aparece un identificador de la llamada. En SIP, <i>Caller</i>-ID. Una persona puede decidir si contesta o no. Automatizar dicha pol&iacute;tica ser&iacute;a un servicio que compare la identidad de los suscriptores potenciales contra una lista blanca (<i>WitheList</i>) antes de determinar si se acepta la llamada o no <a href="#f2">(Figura 2)</a>.</p>      <p align="center"><a name="f2"><img src="img/revistas/inun/v15n2/v15n2a14f2.jpg"></a></p>      <p>El servicio de autenticaci&oacute;n SIP SAML est&aacute; basado en el URI y tiene la siguiente informaci&oacute;n requerida:</p>  <ul>     <li>Identificaci&oacute;n: urn:ietf:params:sip:sip-saml-profile:as:uri:attr:1.0.</li>     <li>Como todo URN debe estar registrado con la Internet Assigned Numbers Authority (IANA).</li>     <li>Informaci&oacute;n del contacto: este incluye la informaci&oacute;n del contacto.</li>     <li>Identificadores de los m&eacute;todos de confirmaci&oacute;n SAML: se toma de la especificaci&oacute;n SAML 2.0.</li>     <li>Descripci&oacute;n: descripci&oacute;n del perfil.</li>     </ul>      <p>A continuaci&oacute;n se describen los pasos ilustrados en la imagen anterior:</p>  <ul>     ]]></body>
<body><![CDATA[<li>Paso 1. Transacci&oacute;n inicial entre el emisor y SA.</li>     <li>Paso 2. El emisor env&iacute;a un mensaje de petici&oacute;n SIP con credenciales de autorizaci&oacute;n al SA.</li>     <li>Paso 3. El SA autoriza la petici&oacute;n SIP y la reenv&iacute;a al receptor.</li>     <li>Paso 4. El receptor de referencia URI SAML basado en HTTP</li>     <li>Paso 5. El SA retorna una aserci&oacute;n SAML.</li>     <li>Paso 6. El receptor devuelve un 200 OK al emisor.</li>     </ul>      <p><b><font size="3">1. Comportamiento para el servicio de autenticaci&oacute;n</font></b></p>      <p>Primero. Se debe extraer la identidad del emisor de la petici&oacute;n. El servicio de autenticaci&oacute;n toma dicho valor del campo de la cabecera <i>From</i>. Esta Address of Record (AoR) ser&aacute; tomada como el campo de identidad (<i>identitiy field</i>). Si este campo contiene un URI SIP o SIPS, el servicio de autenticaci&oacute;n debe extraer la porci&oacute;n del host del campo de identidad y compararlo con el del dominio, de lo cual est&aacute; encargado (Secci&oacute;n 16.4 del RFC3261). Si el servicio de autenticaci&oacute;n no est&aacute; encargado de la identidad en cuesti&oacute;n, este deber&iacute;a procesar y responder la petici&oacute;n normalmente, pero no debe agregar una cabecera de identidad.</p>      <p>Segundo. El servicio de autenticaci&oacute;n debe determinar si el emisor de la petici&oacute;n est&aacute; autorizado para reclamar la identidad dada en el campo de identidad. Para llevar a cabo lo anterior, el servicio debe autenticar al emisor del mensaje. Por ejemplo: si el servicio de autenticaci&oacute;n es instado por un intermediario SIP (<i>proxy</i>), este puede intercambiar la petici&oacute;n con una respuesta 407 usando el esquema de autenticaci&oacute;n <i>Digest</i> (Franks et &aacute;l., 1999). Igualmente puede revisar la cabecera <i>Proxy-Authentication </i>enviada en la petici&oacute;n, que fue enviada antes del intercambio, usando credenciales en cach&eacute; (secci&oacute;n 22.3 RFC3261). Si el servicio de autenticaci&oacute;n es instado por un AU SIP se puede decir que autentica su usuario en cuanto a que el usuario puede otorgarle al AU la llave privada del dominio o una contrase&ntilde;a de desbloqueo.</p>      ]]></body>
<body><![CDATA[<p>Tercero. El servicio de autenticaci&oacute;n deber&iacute;a asegurar que alguna cabecera de fecha Date en la petici&oacute;n sea correcta. Pol&iacute;ticas locales pueden dictaminar c&oacute;mo se debe hacer la precisi&oacute;n de este campo. El RFC3261 recomienda una discrepancia de m&aacute;ximo diez minutos, para asegurar que la petici&oacute;n no sobrepase ning&uacute;n verificador. Si esta cabecera contiene una hora diferente, mayor a diez minutos de la hora actual (seg&uacute;n el servicio de autenticaci&oacute;n), el servicio debe rechazar la petici&oacute;n. Finalmente, se debe verificar que la cabecera de fecha cuadre dentro de los per&iacute;odos de validez del certificado.</p>      <p>Cuarto. El servicio de autenticaci&oacute;n debe hacer la firma de identidad y agregar la cabecera de identidad a la petici&oacute;n que contiene la firma. Luego se agrega la cabecera<i> Identitiy-Info,</i> la cual contiene un URI donde se puede adquirir el certificado. Finalmente, el servicio de autenticaci&oacute;n debe reenviar el mensaje normalmente.</p>      <p><b><font size="3">2. Comportamiento de un verificador</font></b></p>      <p>Este puede ser instanciado por un AU o un <i>proxy</i>. Cuando un verificador recibe un mensaje SIP que contiene una cabecera de identidad, este debe revisar la firma y verificar la identidad del emisor del mensaje. Si dicha cabecera no est&aacute; presente en una petici&oacute;n y se requiere, entonces se puede enviar una respuesta 428 (<i>Use Identity Header</i>). Para verificar la identidad el emisor del mensaje, un verificador deber seguir los siguientes pasos (<a href="#f3">Figura 3</a>):</p>      <p>Primero. Adquirir los certificados del dominio firmante. Dado que el certificado del dominio usado para firmar el mensaje no es conocido previamente por el receptor, las entidades SIP deber&iacute;an descubrir dicho certificado por medio de la cabecera<i> Identity Info,</i> a menos que se cuente con un servicio de b&uacute;squeda de certificados. Si el esquema del URI en la cabecera <i>Identity-Info</i> no puede referenciarse, entonces se puede enviar un mensaje 436 Bad <i>Identity-Info</i>. El cliente procesa este certificado de formas usuales, incluyendo el chequeo de que no haya expirado, de que la cadena valida hacia una entidad certificadora de confianza y que esta no aparece en listas de revocaci&oacute;n (certificados no v&aacute;lidos). Una vez el certificado es adquirido, este deber ser validado usando los procedimientos definidos en el RFC3280 (Rosenberg, 2006). Si el certificado no puede ser validado (est&aacute; autofirmado y no es confiable o est&aacute; firmado por una entidad desconocida o no confiable, se venci&oacute; o fue revocado), se debe enviar un mensaje 437 (<i>Unsupported Certificate</i>).</p>      <p>Segundo. El verificador debe determinar si el firmante est&aacute; autorizado para el URI en el campo de la cabecera <i>From.</i></p>      <p>Tercero. Se debe verificar la firma en el campo de la cabecera de identidad, siguiendo los procedimientos para generar una cadena hash. Si el verificador determina que la firma en el mensaje no corresponde con la reconstruida, entonces se env&iacute;a un mensaje 438 (<i>Invalid Identity Header</i>).</p>      <p>Cuarto. Se deben validar las cabeceras de fecha, contacto e ID de la llamada (<i>date, contact y call-ID</i>). As&iacute; mismo, asegurar que el valor de la cabecera <i>date </i>encaje dentro del periodo de validez del certificado, cuya llave privada fue usada para firmar la cabecera de identidad.</p>      <p align="center"><a name="f3"><img src="img/revistas/inun/v15n2/v15n2a14f3.jpg"></a></p>      <p><b><font size="3">3. Java SIP-JAIN API</font></b></p>      ]]></body>
<body><![CDATA[<p>Actualmente, en el mercado se encuentran varias API para SIP versi&oacute;n 2 (Franks, 2009),la API JAIN SIP que soporta las funcionalidades del RFC 3261 y las siguientes extensiones; el m&eacute;todo INFO (RFC 2976), fiabilidad de las respuestas provisionales (RFC 3262); el Framework para la notificaci&oacute;n de eventos (RFC 3265); el m&eacute;todo<i> Update</i> (RFC 3311), el encabezado <i>Reason </i>(RFC 3326); el m&eacute;todo <i>Message </i>(RFC 3428), definido para la mensajer&iacute;a instant&aacute;nea, y el m&eacute;todo REFER (RFC 3515) (Rosenberg, 2006).</p>      <p>Este paquete contiene las principales interfaces que modelan la arquitectura JAIN SIP desde la vista del desarrollador de aplicaciones y del vendedor:</p>      <p><i>Vista del desarrollador</i>. Se trata de la implementaci&oacute;n de la interfaz <i>SipListener</i>. Esta define los m&eacute;todos requeridos por las aplicaciones para recibir y procesar mensajes de los vendedores SIR Un <i>SipProvider</i> recibe mensajes de la red SIP que encapsula dichos mensajes como eventos y los pasa a su <i>SipListener</i> registrado. Una aplicaci&oacute;n debe registrarse con <i>SipProvider </i>para escuchar eventos dada la implementaci&oacute;n de la interfaz SipListener. Una sola interfaz <i>SipListener</i> es obligatoria dentro de la arquitectura JAIN SIP.</p>      <p><i>Vista de los vendedores.</i> El vendedor implementa todas las interfaces en la especificaci&oacute;n JAIN SIP excluyendo la interfaz <i>SipListener</i>; sin embargo, las dos interfaces m&aacute;s importantes desde el punto de vista arquitectural son la <i>SipStack</i> y la <i>SipProvider.</i></p>      <p><i>SipStack.</i> Esta interfaz puede verse como una de gesti&oacute;n de la arquitectura JAIN SIP y solamente una puede existir por direcci&oacute;n IR Esta interfaz encapsula las caracter&iacute;sticas de administraci&oacute;n de SIP como <i>ListeningPoints</i>, puntos de escucha que encapsulan el puerto y el transporte.</p>      <p><i>SipProvider.</i> Esta interfaz puede verse como la de mensajer&iacute;a de la arquitectura JAIN SIP. Multiples <i>SipProviders</i> son permitidos dentro de la arquitectura. Esta interfaz define los m&eacute;todos con los cuales se implementa una aplicaci&oacute;n para que el <i>SipListener</i> se registre con el SipProvider y recibir peticiones entrantes y responderlas. Los m&eacute;todos definidos para enviar mensajes SIP son tambi&eacute;n definidos dentro de la interfaz <i>SipProvider</i> (Saverio, 2008; Dean y Keith, 2009).</p>      <p>La implementaci&oacute;n m&aacute;s popular que se tiene de esta API se puede encontrar en la misma p&aacute;gina de JAIN. El proyecto se llama <i>sip-comunicator</i> (Helim y Ranga, 2002). Igualmente, en la p&aacute;gina del National Institute of Standards and Technology (NIST) se puede encontrar el proyecto NIST-SIP, con bastante documentaci&oacute;n y algunas herramientas <a href="#f4">(Figura 4)</a>.</p>      <p align="center"><a name="f4"><img src="img/revistas/inun/v15n2/v15n2a14f4.jpg"></a></p>      <p>B&aacute;sicamente, la JainSipAPI se encargar&iacute;a de dos tareas: recibir peticiones y responder a ellas. Los dos comportamientos llevados a cabo por un UAS y un UAC, respectivamente. Con ello se depender&iacute;a de los siguientes puntos:</p>  <ul>     <li>Crear la nueva cabecera.</li>     ]]></body>
<body><![CDATA[<li>Crear los nuevos campos para la cabecera.</li>     <li>Definir en qu&eacute; puntos ser&iacute;a analizada e implementar el an&aacute;lisis.</li>     <li>Implementar la firma de las cabeceras y su resumen dentro de la nueva cabecera.</li>     <li>Implementar la verificaci&oacute;n de las firmas.</li>     <li>Crear los atributos de la llamada.</li>     <li>Enviarlos dentro de la cabecera.</li>     <li>Analizar los datos de la llamada.</li>     <li>Aceptar o rechazar la llamada.</li>     </ul>      <p><b><font size="3">4. Desarrollo</font></b></p>      ]]></body>
<body><![CDATA[<p>Una vez configurado el entorno de programaci&oacute;n, ya se puede iniciar el desarrollo (<a href="#f5">Figura 5</a>).</p>      <p align="center"><a name="f5"><img src="img/revistas/inun/v15n2/v15n2a14f5.jpg"></a></p>  <ul>     <li>Crear la nueva cabecera.</li>     <li>Crear los nuevos campos para la cabecera (<a href="#f6">Figura 6</a>).</li>     </ul>      <p align="center"><a name="f6"><img src="img/revistas/inun/v15n2/v15n2a14f6.jpg"></a></p>  <ul>     <li>Definir en qu&eacute; puntos ser&iacute;a analizada e implementar el an&aacute;lisis (<a href="#f7">Figura 7</a>).</li>     </ul>      <p align="center"><a name="f7"><img src="img/revistas/inun/v15n2/v15n2a14f7.jpg"></a></p>      <p>En este punto, ya se sabe d&oacute;nde se va a tocar el API para que tambi&eacute;n analice la nueva extensi&oacute;n. En el proveedor SIP en el evento de registro. Justo entre el listener y el proveedor. Por consiguiente, lo que hace falta es ubicar esto dentro del c&oacute;digo <i>wrapper</i> implementado.</p>  <ul>     ]]></body>
<body><![CDATA[<li>Implementar la firma de las cabeceras y su resumen dentro de la nueva cabecera. En este caso se trata del evento de inicio (sign in). Se firman las cabeceras del registro y se env&iacute;an:</li> <i>     <p>IdentityHeader identityHeaderL = new IdentityHeader(); identityHeaderL.setValue(signedHeaders);     <br> SIPHeader identityHeader = (SIPHeader)headerFactory.createHeader("Identity", signedHeaders); br> request.setHeader(identityHeader);     <br> SIPHeader identityHeader2 = (SIPHeader)request.getHeader("Identity"); ClientTransaction clientTransaction =      <br> sipProvider.getNewClientTransaction(request); clientTransaction.sendRequest();</p> </i>     </ul>      <p>Se cre&oacute; un certificado digital de ejemplo llamado test.cer. Este fue generado usando la herramienta <i>KeyTool.</i> Para autenticar a los usuario del dominio (figuras <a href="#f8">8</a> a <a href="#f11">11</a>).</p>      <p align="center"><a name="f8"><img src="img/revistas/inun/v15n2/v15n2a14f8.jpg"></a></p>      <p align="center"><a name="f9"><img src="img/revistas/inun/v15n2/v15n2a14f9.jpg"></a></p>      <p align="center"><a name="f10"><img src="img/revistas/inun/v15n2/v15n2a14f10.jpg"></a></p>      ]]></body>
<body><![CDATA[<p align="center"><a name="f11"><img src="img/revistas/inun/v15n2/v15n2a14f11.jpg"></a></p>  <ul>     <li>Implementar la verificaci&oacute;n de las firmas <a href="#f12">(Figura 12)</a></li>     </ul>      <p align="center"><a name="f12"><img src="img/revistas/inun/v15n2/v15n2a14f12.jpg"></a></p>      <p>La verificaci&oacute;n se realiza en el <i>proxy</i> cuando procesa una respuesta. Al inicio puede verificar la nueva extensi&oacute;n y no aceptar la llamada si encuentra que las firmas no coinciden <a href="#f13">(Figura 13)</a>.</p>      <p align="center"><a name="f13"><img src="img/revistas/inun/v15n2/v15n2a14f13.jpg"></a></p>      <p>Con la verificaci&oacute;n (figuras <a href="#f14">14</a> y <a href="#f15">15</a>) se acabar&iacute;a la transacci&oacute;n, y al agente le tocar&iacute;a volver a intentar:</p>  <ul>     <li>Crear los atributos de la llamada.</li>     <li>Enviarlos dentro de la cabecera.</li>     <li>Analizar los datos de la llamada.</li>     ]]></body>
<body><![CDATA[<li>Aceptar o rechazar la llamada (<a href="#f16">Figura 16</a>).</li>     </ul>      <p align="center"><a name="f14"><img src="img/revistas/inun/v15n2/v15n2a14f14.jpg"></a></p>      <p align="center"><a name="f15"><img src="img/revistas/inun/v15n2/v15n2a14f15.jpg"></a></p>      <p align="center"><a name="f16"><img src="img/revistas/inun/v15n2/v15n2a14f16.jpg"></a></p>      <p><b><font size="3">5. Resultados </font></b></p>      <p>Para llevar a cabo el desarrollo, se utiliz&oacute; un equipo (Equipo 1) con las siguientes caracter&iacute;sticas: un procesador AMD 1800 + 1,6 GHZ 800 FSB; una memoria de 1 GB; red de 100 Mbps. Adem&aacute;s, se conect&oacute; al Equipo 2 por un cable directo.</p>      <p>Para llevar a cabo las pruebas, el equipo anterior estuvo a cargo de un <i>proxy</i> y un agente; adicionalmente, se utiliz&oacute; otro equipo (Equipo 2), encargado de uno de los agentes, con las siguientes caracter&iacute;sticas: procesador AMD K II 500 MHZ 100 FSB; memoria de 256 MB; red de 100 Mbps. Se conect&oacute; al Equipo 1 por un cable directo.</p>      <p>Finalmente, para realizar pruebas de carga, se utiliz&oacute; un tercer equipo (Equipo 3) con otro<i> proxy</i> y un agente: procesador Intel Pentium 4 HT 3,2 GHZ-3,2 GHZ (que emula dos procesadores); memoria de 2 GB; red de 100 Mbps y 1 Gbps. Se conect&oacute; al Equipo 1 a trav&eacute;s de internet (1Mbps Equipo 3 <i>vs.</i> 400 Kbps al Equipo 1).</p>      <p>Se observ&oacute; que cada agente consume en promedio 28 MB de memoria RAM. El <i>proxy</i> consume la misma memoria RAM de un agente (estos datos fueron obtenidos usando la sentencia tasklist /FI "IMAGENAME eq java&#42;, que retorna caracter&iacute;sticas como el consumo de memoria y CPU de cierto proceso en el SO WIN XP).</p>      ]]></body>
<body><![CDATA[<p>El gasto de procesador para los agentes es m&iacute;nimo (10% a 15%). Incluso el <i>proxy</i> fue capaz de mantener hasta 100 llamadas sin p&eacute;rdida de rendimiento. El mayor gasto se present&oacute; en la red. Es interesante que con solo IM el gasto de la red aumentara en un 20%.</p>      <p>El m&eacute;todo de prueba fue b&aacute;sicamente en los mensajes. El experimento consisti&oacute; en un agente que dispar&oacute; (inici&oacute;) llamadas con diversas cuentas origen ficticias, durante doce horas, hacia un conjunto de direcciones bajo la administraci&oacute;n de un <i>proxy </i>(<a href="#f17">Figura 17</a>). Este &uacute;ltimo se mantuvo estable. Como se puede observar el consumo fue m&aacute;s de memoria que de CPU. Esto quiz&aacute;s a la cantidad de transacciones que tuvo que mantener, al igual que los registros, pues, como se sabe, no se us&oacute; ninguna base de datos (figuras <a href="#f18">18</a> y <a href="#f19">19</a>).</p>      <p align="center"><a name="f17"><img src="img/revistas/inun/v15n2/v15n2a14f17.jpg"></a></p>      <p align="center"><a name="f18"><img src="img/revistas/inun/v15n2/v15n2a14f18.jpg"></a></p>      <p align="center"><a name="f19"><img src="img/revistas/inun/v15n2/v15n2a14f19.jpg"></a></p>      <p>El consumo de ancho de banda es muy positivo: no consume un gran ancho. En promedio, env&iacute;a paquetes de 4 KB. Lo anterior se puede verificar viendo el Log del <i>proxy</i>, pues este registra todos los paquetes y eventos. En las dos horas de funcionamiento continuo lleg&oacute; a 8 MB <a href="#f20">(Figura 20)</a>.</p>      <p align="center"><a name="f20"><img src="img/revistas/inun/v15n2/v15n2a14f20.jpg"></a></p>      <p>Finalmente, en cuanto a SPIT, se gener&oacute; un ciclo en el agente para que dispararan llamadas con bastante frecuencia, usando diferentes atributos, v&aacute;lidos e inv&aacute;lidos. El <i>proxy</i> fue muy r&aacute;pido en responder, teniendo en cuenta que se us&oacute; un tan solo el 50% de CPU de un procesador de 7000 millones de instrucciones por segundo. Los autores se atreven a decir que para un sistema monodominio el uso de SIP <i>Identity</i> realmente es muy bueno, porque el proxy conoce a sus usuarios, conoce su propio certificado y, por ende, SIP <i>Identity</i> es fuerte autenticando usuarios en un solo dominio administrativo (<i>referencia strong authentication</i>).</p>      <p>Falta esperar los resultados del estudio llevado a cabo en <a target="_blank" href="http://www.spitprevention.net/">http://www.spitprevention.net/</a> (Ivov, 2009), que busca implementar un filtro para el SPIT teniendo en cuenta un patr&oacute;n para el comportamiento del SPIT, la identidad de los usuarios, retroalimentaci&oacute;n y uso de SAML. Kayote Networks, quien entre el apoyo de varios investigadores, cuenta con Hannes Tschofenig (pionero en tratar temas sociales y de seguridad para SIP, en casos de emergencia, SPIT, entre otros) y Henning Schulzrinne (creador de SIP).</p>      <p><b><font size="3">6. Conclusiones</font></b></p>      ]]></body>
<body><![CDATA[<p>Este art&iacute;culo presenta una extensi&oacute;n al API JAIN SIP para que este tenga capacidad de utilizar la identidad SIP como mecanismo anti-SPIT. Se muestra la facilidad tecnol&oacute;gica para poder enviar SPIT; sin embargo, tambi&eacute;n la facilidad con la cual se podr&iacute;a evitar al implementar la soluci&oacute;n propuesta.</p>      <p>La soluci&oacute;n propuesta muestra c&oacute;mo de manera sistem&aacute;tica usando <i>software</i> existente es posible crear herramientas anti-SPIT con una simple, mas no sencilla, extensi&oacute;n llamada identidad SIP Este trabajo puede ser considerado uno de los primeros en el pa&iacute;s, pues si bien hay VoIP no se puede medir el potencial de SPIT en el pa&iacute;s -que lidera la penetraci&oacute;n de internet en Am&eacute;rica Latina (Falo-mi, Garroppo y Niccolini, 2007), lo cual lo hace atractivo para generar SPIT al aumentar los usuarios de internet- es importante generar herramientas como la producida con el presente trabajo.</p>      <p>Como trabajo futuro est&aacute; la integraci&oacute;n con otras t&eacute;cnicas anti-SPIT,y su perspectiva en Colombia.</p>  <hr>      <p><b><font size="3">Referencias</font></b></p>      <!-- ref --><p>DEAN, W y KEITH, D. <i>Cap&iacute;tulo de SIP</i> en la IETF &#91;documento en l&iacute;nea&#93; <a target="_blank" href="http://www.ietf.org/">http://www.ietf.org/html.charters/sip-charter.html</a> &#91;Consulta: 10-07-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000137&pid=S0123-2126201100020001400001&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>FALOMI, M.; GARROPPO, R. y NICCOLINI, S. Simulation and optimization of SPIT detection frameworks. <i>Global Telecommunications Conference</i>, 2007. GLOBECOM '07. IEEE. 26-30 Nov 2007, pp. 2156-216. <a target="_blank" href="http://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&amp;arnumber=4411322&amp;isnumber=4410910">http://ieeexplore.ieee.org/stamp/stamp.jsp?tp=&amp;arnumb er = 4411322&amp;isnumber = 4410910</a>.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000138&pid=S0123-2126201100020001400002&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>FRANKS, J.; HALLAM-BAKER, P.; HOSTETLER, J.; LAWRENCE, S. y LEACH, P HTTP <i>authentication. Basic and digest access authentication,</i> RFC 261 7 &#91;documento en l&iacute;nea&#93;. 1999. <a target="_blank" href="http://www.ietf.org/rfc/rfc2617.txt">http://www.ietf.org/rfc/rfc2617.txt</a> &#91;Consulta: 09-07-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000139&pid=S0123-2126201100020001400003&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>HELIM, P. y RANGA, M. <i>Especificaci&oacute;n </i>JSR-000032 JAIN SIP API &#91;documento en l&iacute;nea&#93;. 2002. Java Community Process. <a target="_blank" href="http://www.jcp.org/en/home/index">http://www.jcp.org/aboutJava/communityprocess/ maintenance/jsr032/</a> &#91;Consulta: 08-03-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000140&pid=S0123-2126201100020001400004&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>IVOV, E.<i> Proyecto cliente</i> VoIP para SIP, "<i>Sip-communicator</i>' &#91;documento en l&iacute;nea&#93;.<a target="_blank" href="http://www.jitsi.org"> http://www.jitsi.org/</a> &#91;Consulta: 07-04-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000141&pid=S0123-2126201100020001400005&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>KAYOTE NETWORKS. <i>Empresa pionera en desarrollo de soluciones contra el</i> SPIT. &#91;web en l&iacute;nea&#93;. <a target="_blank" href="http://www.kayote.com/web/About/Research.htm">http://www.kayote.com/web/About/Research.htm</a> &#91;Consulta: 05-03-2008&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000142&pid=S0123-2126201100020001400006&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>PETERSON, J. y JENNINGS, C. <i>Enhancements for authenticated identity management in the Session Initiation Protocol </i>(SIP), RFC 4474 &#91;documento en l&iacute;nea&#93;. 2006. IETF. <a target="_blank" href="http://tools.ietf.org/html/rfc4474 ">http://tools.ietf.org/html/rfc4474</a> &#91;Consulta: 09-07-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000143&pid=S0123-2126201100020001400007&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>RANGA, M. y HELIM M. <i>Proyecto</i> JAIN SIP. <i>Proyecto</i> JAIN SIP &#91;web en l&iacute;nea&#93; <a target="_blank" href="http://home.java.net/">http://jain-sip.dev.java.net/</a>&#91;Consulta: 08-07-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000144&pid=S0123-2126201100020001400008&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>RENATA: Conectividad en Latinoam&eacute;rica, Colombia lidera penetraci&oacute;n en Internet &#91;web en l&iacute;nea&#93;. <a target="_blank" href="http://200.31.94.218/index.php/noticias/5-noticias/1485-conectividad-en-latinoamerica-colombia-lidera-penetracion-en-internet.html">http://200.31.94.218/index.php/noticias/5-noticias/1485-conectividad-en-latinoamerica-colombia-lidera-penetracion-en-internet.html</a> &#91;Consulta: 23-01-2011&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000145&pid=S0123-2126201100020001400009&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>ROSENBERG, J. A <i>Framework for Consent-Based Communications in the Session Initiation Protocol (SIP) draft-ietf-sipping-consent-framework-05</i> &#91;documento en l&iacute;nea&#93;. 2006. IETF. <a target="_blank" href="http://www.tools.ietf.org/html/draft-ietf-sipping-consent-framework">http://www.tools.ietf.org/html/draft-ietf-sipping-consent-framework</a> &#91;Consulta: 10-072009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000146&pid=S0123-2126201100020001400010&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>ROSENBERG, J. y JENNINGS, C. <i>The Session Initiation Protocol </i>(SIP) <i>and Spam</i>. &#91;documento en l&iacute;nea&#93;. 2007. IETF, <a target="_blank" href="http://tools.ietf.org/html/draft-ietf-sipping-spam-05">http://tools.ietf.org/html/draft-ietf-sipping-spam-05</a> &#91;Consulta: 07-10-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000147&pid=S0123-2126201100020001400011&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>SAVERIO, N. SPIT prevention state of the art and research challenges &#91;documento en l&iacute;nea&#93;. 2008. <i>Third Annual VoIP Security Workshop.</i> <a target="_blank" href="http://old.iptel.org/voipsecurity/doc/07%20-%20Niccolini%20-%20SPIT%20prevention%20state%20of%20the%20art%20and%20research%20challenges.pdf">http://old.iptel.org/voipsecurity/doc/07%20-%20Niccolini%20-%20SPIT%20prevention%20state%20of%20the%20art%20and%20research%20challenges.pdf</a> &#91;Consulta: 10-07-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000148&pid=S0123-2126201100020001400012&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>STEWART, L. HTTP <i>Authentication: Basic and Digest Access Authentication</i>, RFC 2617. <a target="_blank" href="http://www.ietf.org/rfc/rfc2617.txt">http://www.ietf.org/rfc/rfc2617.txt</a>.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000149&pid=S0123-2126201100020001400013&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --><!-- ref --><p>UTILIDAD PARA CERTIFICADOS DIGITALES Y JAVA &#91;web en l&iacute;nea&#93;. <a target="_blank" href="http://java.sun.com/j2se/1.3/docs/tooldocs/win32/keytool.html">http://java.sun.com/j2se/1.3/docs/tooldocs/win32/keytool.html</a> &#91;Consulta: 06-05-2009&#93;.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;[&#160;<a href="javascript:void(0);" onclick="javascript: window.open('/scielo.php?script=sci_nlinks&ref=000150&pid=S0123-2126201100020001400014&lng=','','width=640,height=500,resizable=yes,scrollbars=1,menubar=yes,');">Links</a>&#160;]<!-- end-ref --> ]]></body><back>
<ref-list>
<ref id="B1">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[DEAN]]></surname>
<given-names><![CDATA[W]]></given-names>
</name>
<name>
<surname><![CDATA[KEITH]]></surname>
<given-names><![CDATA[D]]></given-names>
</name>
</person-group>
<source><![CDATA[Capítulo de SIP en la IETF]]></source>
<year></year>
</nlm-citation>
</ref>
<ref id="B2">
<nlm-citation citation-type="confpro">
<person-group person-group-type="author">
<name>
<surname><![CDATA[FALOMI]]></surname>
<given-names><![CDATA[M]]></given-names>
</name>
<name>
<surname><![CDATA[GARROPPO]]></surname>
<given-names><![CDATA[R]]></given-names>
</name>
<name>
<surname><![CDATA[NICCOLINI]]></surname>
<given-names><![CDATA[S]]></given-names>
</name>
</person-group>
<source><![CDATA[Simulation and optimization of SPIT detection frameworks]]></source>
<year></year>
<conf-name><![CDATA[ Global Telecommunications Conference]]></conf-name>
<conf-date>2007</conf-date><conf-date>26-30 Nov 2007</conf-date>
<conf-loc> </conf-loc>
<page-range>2156-216</page-range></nlm-citation>
</ref>
<ref id="B3">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[FRANKS]]></surname>
<given-names><![CDATA[J]]></given-names>
</name>
<name>
<surname><![CDATA[HALLAM-BAKER]]></surname>
<given-names><![CDATA[P]]></given-names>
</name>
<name>
<surname><![CDATA[HOSTETLER]]></surname>
<given-names><![CDATA[J]]></given-names>
</name>
<name>
<surname><![CDATA[LAWRENCE]]></surname>
<given-names><![CDATA[S]]></given-names>
</name>
<name>
<surname><![CDATA[LEACH]]></surname>
<given-names><![CDATA[P]]></given-names>
</name>
</person-group>
<source><![CDATA[HTTP authentication. Basic and digest access authentication, RFC 261 7]]></source>
<year>1999</year>
</nlm-citation>
</ref>
<ref id="B4">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[HELIM]]></surname>
<given-names><![CDATA[P]]></given-names>
</name>
<name>
<surname><![CDATA[RANGA]]></surname>
<given-names><![CDATA[M]]></given-names>
</name>
</person-group>
<source><![CDATA[Especificación JSR-000032 JAIN SIP API]]></source>
<year>2002</year>
</nlm-citation>
</ref>
<ref id="B5">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[IVOV]]></surname>
<given-names><![CDATA[E]]></given-names>
</name>
</person-group>
<source><![CDATA[Proyecto cliente VoIP para SIP, "Sip-communicator']]></source>
<year></year>
</nlm-citation>
</ref>
<ref id="B6">
<nlm-citation citation-type="">
<collab>KAYOTE NETWORKS</collab>
<source><![CDATA[Empresa pionera en desarrollo de soluciones contra el SPIT]]></source>
<year></year>
</nlm-citation>
</ref>
<ref id="B7">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[PETERSON]]></surname>
<given-names><![CDATA[J]]></given-names>
</name>
<name>
<surname><![CDATA[JENNINGS]]></surname>
<given-names><![CDATA[C]]></given-names>
</name>
</person-group>
<source><![CDATA[Enhancements for authenticated identity management in the Session Initiation Protocol (SIP), RFC 4474]]></source>
<year>2006</year>
</nlm-citation>
</ref>
<ref id="B8">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[RANGA]]></surname>
<given-names><![CDATA[M]]></given-names>
</name>
<name>
<surname><![CDATA[HELIM]]></surname>
<given-names><![CDATA[M]]></given-names>
</name>
</person-group>
<source><![CDATA[Proyecto JAIN SIP]]></source>
<year></year>
</nlm-citation>
</ref>
<ref id="B9">
<nlm-citation citation-type="">
<collab>RENATA</collab>
<source><![CDATA[Conectividad en Latinoamérica, Colombia lidera penetración en Internet]]></source>
<year></year>
</nlm-citation>
</ref>
<ref id="B10">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[ROSENBERG]]></surname>
<given-names><![CDATA[J. A]]></given-names>
</name>
</person-group>
<source><![CDATA[Framework for Consent-Based Communications in the Session Initiation Protocol (SIP) draft-ietf-sipping-consent-framework-05]]></source>
<year>2006</year>
</nlm-citation>
</ref>
<ref id="B11">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[ROSENBERG]]></surname>
<given-names><![CDATA[J]]></given-names>
</name>
<name>
<surname><![CDATA[JENNINGS]]></surname>
<given-names><![CDATA[C]]></given-names>
</name>
</person-group>
<source><![CDATA[The Session Initiation Protocol (SIP) and Spam]]></source>
<year>2007</year>
</nlm-citation>
</ref>
<ref id="B12">
<nlm-citation citation-type="confpro">
<person-group person-group-type="author">
<name>
<surname><![CDATA[SAVERIO]]></surname>
<given-names><![CDATA[N]]></given-names>
</name>
</person-group>
<source><![CDATA[SPIT prevention state of the art and research challenges]]></source>
<year>2008</year>
<conf-name><![CDATA[ Third Annual VoIP Security Workshop]]></conf-name>
<conf-loc> </conf-loc>
</nlm-citation>
</ref>
<ref id="B13">
<nlm-citation citation-type="">
<person-group person-group-type="author">
<name>
<surname><![CDATA[STEWART]]></surname>
<given-names><![CDATA[L]]></given-names>
</name>
</person-group>
<source><![CDATA[HTTP Authentication: Basic and Digest Access Authentication, RFC 2617]]></source>
<year></year>
</nlm-citation>
</ref>
<ref id="B14">
<nlm-citation citation-type="">
<source><![CDATA[UTILIDAD PARA CERTIFICADOS DIGITALES Y JAVA]]></source>
<year></year>
</nlm-citation>
</ref>
</ref-list>
</back>
</article>
